読者です 読者をやめる 読者になる 読者になる

tohokuaikiのチラシの裏

技術的ネタとか。

Confluenceのプラグイン開発を承ります。ご連絡はこちらのホームページからお願いいたします。

Atlassian SDKの5.1.11が微妙。。。

confluence

なんか5.3.1の実機にインストールしてみたところエラーでる。

2015-08-27 17:16:01,408 ERROR [http-8191-6] [plugin.descriptor.web.ConfluenceWebInterfaceManager] getHtml Failed to render web panel: com.atlassian.plugin.web.descriptors.DefaultWebPanelModuleDescriptor$ContextAwareWebPanel@23222f4e
-- url: /login.action | userName: anonymous
java.lang.NullPointerException
at jp.junoe.confluence.plugins.googleanalyticsid.webpanel.TrackingScript.getContextMap(TrackingScript.java:60)

SDKを5.0.13にしたところ、問題なかった。

AtlassianMarketPlaceライセンスライブラリ回りでもConfluenceが起動できないとかいう最悪なエラーが出たりで・・・・。

なんか、AtlassianSDKって結構当たり外れあって、自分はずっと4.2.20を使ってたりしたんだけど。。。

しばらく5.0.13にするかなぁ。。。