tohokuaikiのチラシの裏

技術的ネタとか。

Confluenceのプラグイン開発を承ります。ご連絡はこちらのホームページからお願いいたします。

LinuxのディストリビューションとデフォルトパッケージのPHPバージョンの一覧

ディストリビューション バージョン サポート終了 PHPのバージョン
CentOS 5 2017/3/31 5.1
CentOS 6 2020/11/30 5.3
CentOS 7 2024/6/30 5.4
Debian 7 2018/5/31 5.4
Debian 8 2020/4/30 ? 5.6
Ubuntu(LTS) 14 2019/4/30 5.5
Ubuntu(LTS) 16 2021/4/30 7

Laravel が必要とするPHPのバージョンの一覧

Release Notes - Laravel - The PHP Framework For Web Artisansから作成

Laravel PHPのバージョン
4.2 5.4
5.0 5.4
5.1 5.5.9
5.2 5.5.9
5.3 5.5.9

んー、でも現時点で https://laravel.com/docs/5.3#server-requirements を見ると 5.6.4が必要らしい。