読者です 読者をやめる 読者になる 読者になる

tohokuaikiのチラシの裏

技術的ネタとか。

Confluenceのプラグイン開発を承ります。ご連絡はこちらのホームページからお願いいたします。

mb_convert_encodingがUTF16を扱うと文字列を壊す件

php

旧聞で恐縮ですが、自分用まとめメモ。

2009/9/11

mbstringerといえばこの方moriyoshiさん。パッチをPHP本体に投稿
https://bugs.php.net/bug.php?id=49528

[2009-09-23 14:27 UTC] moriyoshi@php.net

ということで、この日以降のリリースは直っていることになる。

UTF16が影響なく使えるバージョンは・・・

http://www.php.net/releases/
から

  • 5.2.12(Released: 17 December 2009)以降のPHP5.2
  • 5.3.1(Released: 19 Nov 2009)以降のPHP5.3

ということになる。PHP5.3.0はN.Gなので注意。